Exec-phpは非奨励

PHPのバージョンを最新の「PHP7.0.7」に変更した。そうしたらExec-phpが機能せず、エラーメッセージが出た。

さらにExec-phpはセキュリティ的にもよくないということだったので、以下のサイトを参考に、「PHP code widget」を導入した。そうするとウィジェットでもPHPは動いたし、PHPのバージョンを上げても正常に機能した。めでたしめでたし

Exec-PHPは危険!記事内PHPを Post Snippets で一元化しよう – WordPress プラグイン

サブコンテンツ

このページの先頭へ